Reporting available apps

Dear readers,
I am delighted to report those applications are in working order under MacOSX 10.12.6 (Japanese circumstances).

・NisusWriter Pro (ver3.0.3)
・Zettelkasten(ver3.2.7-Build 20151016)

Unfortunately the following apps could not be used.

・CotEditor(Markdown file can paste Link, but does not call up it’s URL)
・egwordUniversal 2

Best regards, WAKAMATSU

1 Like

Thanks for letting us know, @Hook8Kuni.

I’ve updated the forum with links to this post.

Are you referring The Archive (macOS)?

Thank you. We will look into them.

Dear LucB,
About Zettelkasten 3.2.7
I am afraid that Zettelkasten is not “The Archive” for Mac.

I used to use this app.

Zettelkasten 3.2.7
Zkn3(nach Niklas Luhmann)
Autor : Daniel Lüdecke
E-Mail :
Web :

Time to quit.

Dear All,
I find an interesting comment about Zettelkasten3.

[ Switching from Zkn³ to a Plain Text Approach ]



thank you. I see we had another request for this before. We’ll re-examine.

Thanks, very interesting list of requirements. Pertinent to Hook. Some are things we have in our issue system.

here’s another one for scholars: it should be possible to bring up Hook in a PDF and do “copy as doi” (if applicable). Cf DOIs and URLs, and to get from there to the main web page related to the DOI.

Dear LucB,
If you have an interresting about
Please visit the following site URL.
[ ]

[ CalendarMemo ver 1.8.6 full ]

“Bring up Hook”? What does that mean? In what context is the PDF – browser, a PDF app?

Reissued report:
Zettelkasten 3 is lack of facility with DEVONthink3 or iTextPro.
Zkn3 carries out a function “Copy & Paste” from all types of Browsers.

I would like to ask this information for Hook Forum to make a correction.


I meant “in context of a PDF”.

Suppose I am reading a published scholarly PDF of an article in a PDF reader (like PDFPenPro). That article probably has a doi. The doi is used to uniquely and globally identify the article. it would be nice (for people who read and write such articles, and/or teach with them) for Hook to enable the user to retrieve this with a command. The feature would depend on an advanced preference. I just mentioned it because there was a connection with the article linked by @Hook8Kuni. The feature’s usefulness will be more obvious later. It is not coming very soon.

Reporting available apps

de novo repo about garbage characters

I found curious garbage characters when I use from[LinkCopy(cmd+C)]

To [Link to CopyAddress (cmd+L)]with Nisus Writer Pro

(ver.3.0.3 and v.3.0.4).

I do not know about Hook’s module of information, clip-board from Mac itself or Nisus Writer’s clipboard.
Screen-shot A (with garbage characters) :Hook by Nisus Writer Pro.3shot A-small
Screen-shot B (justify characters) : Hook by iTextPro
shot B-small
I would like to know what is the causal factor.

Additional information about iText Pro with Hook

When I take .txt file with iText Pro, [cmd+C] and paste using [cmd+L],
Hook linked information turn into garbage.
Otherwise, .rtf file have no trouble with same sequenced entry.

I would like to know where the bodies are buried.


Dear all,
I forget an attachment png file.
1/3 upper part is with .rtf,
2/3 inferior part is with .txt extension.
Just for reference.


Thanks for the info, @Hook8Kuni.

The link that looks like garbage characters is URL-encoded in plain text format. Can you please copy and paste the link in a browser to see if it works. If it does not, could you please send us an example source URL so we can try to reproduce the behavior. The URL would need to be a publicly accessible URL, not only accessible in the course of a particular transaction with the website. If the URL results from a transaction, could you please guide us through the steps on the website that lead to the issue?

Please feel free to use a PIM or email rather than the public forum (for any data you do not wish to be public, or whatever).

The RTF formatted link shows the title (the hyperlink would be accessible by control-clicking on it and selecting the appropriate context menu; or ⌘K on a keyboard with US layout).

Dear LucB.

URL is here.インチMacbook-Pro-29GHzクアッドコアIntel-Core-i7-Retinaディスプレイモデル-スペースグレイ-整備済製品?fnode=483bd687d7227d2a80cf19131a941c6faa25ba3d1ed0701bfc228fdbc0dc5d4c2bd645e16f636e38134576d42258d058ff2ac45256596ce780e1454e2162a8d2ef53891f51aa2eb7ee038ee1c2430f98

With, I use the utf-8 code for txt. file and .rtf.files.

I look forward to hearing from you at your earliest convenience.

RTF format has no problem for me.

Thanks again, @Hook8Kuni.

we were able to copy the link to this pageインチMacbook-Pro-29GHzクアッドコアIntel-Core-i7-Retinaディスプレイモデル-スペースグレイ-整備済製品?fnode=483bd687d7227d2a80cf19131a941c6faa25ba3d1ed0701bfc228fdbc0dc5d4c2bd645e16f636e38134576d42258d058ff2ac45256596ce780e1454e2162a8d2ef53891f51aa2eb7ee038ee1c2430f98

and make use of it in Hook. Our tests have not yet been with iText Pro. I’ve tried it in a .txt file in TextEdit saved as UTF-8 and was able to copy the URL back into Safari directly and via LaunchBar and still access the page. So, it seems to be an issue with iText Pro, which has not been updated since 2015… Have you tried other encodings?

Are you sure this has anything to do with Hook? what if you copy and paste the URL directly from Safari into iText Pro? If it doesn’t work, I would recommend getting in touch with the developer.

So in sum: Hook is returning the correct, validly encoded URL, and that URL works. There’s no bug in Hook here. It is not a pretty URL, but that is not a bug. It’s just what Apple is returning. Hook’s Copy Link function is designed to populate the clipboard with the name and URL parts of the links, and it is doing that. Most websites/webpages provide a nice name.

I don’t think there’s a bug in iText Pro either.

When you paste in RTF you see the nice name. When you paste in a plain text field, you will typically see the URL.

If you want to see the name and the URL, you may use the Copy Markdown Link command (Pro feature of Hook).

Please keep in mind that it is the app in which the paste happens that is ultimately responsible for responding to the paste commands. There is a small % of apps that mishandle the paste command. Slack until the last week or two was one of them. When you would paste a link (whether it originated from Hook or from a third party app’s Copy Link command) into a Slack message, Slack would take (paste) the name, not the URL. Slack has fixed that. If you encounter an app that responds to “paste” by pasting the name instead of the link, we recommend using Copy Markdown Link instead, so you get both the name and the URL. But it’s up to users.

Dear LucB,
Thank you for your help and a lot for your validate the evidence.
For me with iTextPro(yes, it is old enough to use now a day.),
iText Pro’s .rtf file has no trouble with
In your initial action to comply with Hook.
My mistake has been found what born of a misunderstanding to use Hook CMD.
I am afraid I do not have enough field of knowledge.
I try to make a selection and resorting about applications for logical age over 70. Make day-to-day progress is familiar routine for professional musician. makes me a step forward.
Let bring the topic back to Hook.
I am glad to give these informations. and iText, both of them can carry out a function to use the Copy Markdown Link command.
(I do not know how I explain about this behaviour. JavaScript for Web, have something similar idiom, I believe. )
I forget to use Right click Button which can allow to access intended URL.
In the document where I use Copy Markdown Link command with those applications.
Anyway, On cursor Over (onMouse over?) then [open URL] menu using mouse right clicking, moving on it’s menu, Left click-button On.
I can jump to intended URL from even garbled characters are written on the page.

Additionally BBEdit can use [cmd+M] & [cmd+L] then paste on my Note. After this Markdown site. I get to use successful mouse right Click jumping to intended URL.

I would like to say about, more.
I can copy using Hook[cmd+C] and , now possible [Jump to URL] in it’s pasted document.

Qte does not look that great.
15.4インチMacBook Pro 2.9GHzクアッドコアIntel Core i7 Retinaディスプレイモデル - スペースグレイ [整備済製品] - Apple(日本)