Not working with Craft : Answer requires Craft Version 1.3.7 and Big Sur

I just signed up with the Craft deal, followed all the instructions, and no linkable content comes up when call up Hook. Checked security settings. Restarted everything.

Welcome to the Hook Productivity Forum , @lanceelyot . Please make sure that you’re using Craft version 1.3.7. Previous version had a glitch with Hook.

Several users have confirmed that Hook and Craft version 1.3.7 do work well together.

You also need to update your Hook integration scripts via Hook’s Software Updates Tab (in its Preferences)). Please make sure you have version 165. You can also use the Gear menu to do an update.

2021-03-17 10:26 AM. version correct to 165 (not 167).

Confirmed. I updated before installing Hook.

I looked at the scripts and it says bundle version 156, but is was updated today. Craft is not on the script list. I’m pretty sure I saw previously though.

Okay. I just went to the update button. It said I was already up to date, but then when I went back to the scripts screens, Craft reappeared and now it is working.

1 Like

Thanks for letting us know.

General note: If a newly integrated/updated integration does not appear in the Scripts list, relaunching Hook should fix that.

I’m having difficulty getting Hook to work with Craft as well. I’m on Craft 1.3.7. I’ve checked the Hook scripts and I see Craft in the list, but the scripts version is 165. I’ve checked for updates multiple times, but I can’t seem to download version 167.

My problem is that Hook will launch and I’ll see the linked Craft page show in Hook, but it goes away immediately. It’s on the screen for less than a second.

Welcome to the Hook Productivity Forum , @ddustye .

I’ve now corrected my post above to say version 165 not 167 , sorry about that.

If someone can’t see the latest integration, relaunching Hook should solve the problem.

Per Using Hook with the Craft Mac Writing App – Hook : integration

requires macOS Big Sur.

I’ve updated the title of this topic to indicate the constraint, so others on the forum can get to the bottom line.

we are looking at broadening Hook’s support of Craft to 10.15. Craft itself requires 10.15 or newer. Hook itself works with macOS 10.14 or newer, but there are exceptions for some apps (e.g., Apple
macOS 10.15 [catalina] Notes has a bug that limits what Hook [or other software] can do with it).

I upgraded to Big Sur and Hook and Craft are working now. Thanks!

1 Like

Super, we’ve added a note to the current banner on the home page to make it more obvious. Meanwhile, we’re looking into Craft+Hook macOS 10.15 integration.

1 Like