[FIXED] Hook does not work with Mac App Store's OmniFocus 3

#1

I have OmniFocus 3 installed but it doesn’t show in “Linked to New” dropdown list, and in the Script Editor tab of Preferences it is not shown when the checkbox “only show installed apps” is selected.

Is this a bug in Hook? Or in my MacBook installation?

#2

Sorry for the delay. We tried to replicate this issue but haven’t been able to.

  1. could you please check whether you see an entry for OmniFocus in Hook’s > Preferences > Script Editor pane? First try with “ONly show installed apps” checked (bottom right of that screen). If you can’t see it. Please try unchecking that checkbox and see if the script shows up.

  2. Could you also please try running the “New Document” (subtab) script below in Apple’s Script Editor ( /Applications/Utilities/Script Editor.app). I.e., copy and paste it in Apple’s Script Editor and press the “>” (run) button (at the top of Apple’s script editor window).

The script is:
tell application “OmniFocus”
activate
tell first document
set new_task to make inbox task with properties {name:"$title", note:"$link"}
set new_task_url to “omnifocus:///task/” & (id of new_task)
do shell script "open " & new_task_url
get new_task_url
end tell
end tell

Please let us know if this creates a task in OmniFocus 3 , and what the result is in the “results” pane of the Script editor

Thank you.

We’ll also put together a troubleshooting page illustrating where to find the above information. So if the above is too complex please, not to worry, more information is coming.

Luc

#3

What beta version of Hook are you running?

The OF integration works fine, here. Of course I had to give Hook permission to “control” OF the first time I used the integration.

BTW – I appreciate how the scripting in the background of this allows one to change spelling in the OF action and that does not break the links that Hook knows about. It’s good that these integrations use the internal ID of an item since that makes for less fragility in the integration. Good job on that one, @LucB

1 Like
#4

Hi all, I figured OF3 just wasn’t supported yet, but clearly there’s just a bug. I’m on the latest Hook beta and I’m not seeing OF3 as an option anywhere. I’m going to try an uninstall of Hook completely to see if that resolves it. Right now, Hook WILL link to OF3 but only to the database as a whole–which of course is not very useful! :slight_smile:

#5

Bummer, that didn’t work. Hook just isn’t seeing my OF3 installation and when I use the Link to command, I get a link to Omnifocus.ofocus, which is of course the entire darn database! Would LOVE to get this working.

#6

I’ve replicated with OmniFocus 3 (over macOS over Parallels) from Mac App Store that OmniFocus is not showing up in “Link to New” menu. It’s a high priority of ours to address this.

( 2019-03-13 10-41 PM: oops, I had written “now” above instead of “not”. See clarification below.)

1 Like
#7

Meanwhile, you can still use Hook to copy links from any supported app, and paste them in OmniFocus comments. This is actually what I prefer to do.

And as a stopgap, you can use OF’s own Copy as Link function, and paste in source if possible (e.g., in in markdown docs).

But again, it’s a priority of ours to sort this out. More generally: to ensure that all versions of any supported app function regardless of whether they are from Mac App Store, the vendor’s site, and Set App. (It’s generally working well, but we want to keep exceptions to an absolute minimum, like zero).

1 Like
#8

We’ve fixed the issue, which was due its use of a different bundle ID. To get the fix, please update your scripts by pressing the update button in Hook > Preferences > Script Editor tab. Version 25 of the scripts bundle contains the fix.

(We will provide a unified update mechanism.)

(We’ll generalize the fix in our processes and software.)

1 Like
#9

So my version now sees OmniFocus as installed, but when I invoke Hook with an OF3 task selected, it gives me the no resource found error. And when I try to link something else to a New OF3 task, it simply doesn’t work.

I’ve tested all three scripts with Script Debugger and they work as expected. Any ideas?

@LucB saw your other post, I can see the Create task option now, but it doesn’t work as above.

#10

Have you tried quitting and restarting Hook? It shouldn’t be necessary normally but may be in this case. Sorry: I should have mentioned it.

#11

What version of OF3 do you have: Mac App Store or from OmniGroup?

#12

MAS. And yep, tried restarting both OF3 and Hook. May try a total system reboot just for the heck of it!

#13

My guess at this point then is that this might be a case where it would help to export and then import your Hook database, as described here: General Tab – Hook.

Unfortunately, we haven’t put together a troubleshooting page yet. But these problem reports during Beta will help us design that page. Thank you for your patience.

#14

I don’t suppose you renamed the OmniFocus app? If so, could you try renaming it back to OmniFocus?

#15

Also, are you sure you gave Hook permission to access : System Preferences > Security & Privacy > Automation (LEFT) > Privacy (top right tab): Under Hook , make sure that OmniFocus has a checkmark.

#16

:man_facepalming:
I had adjusted that earlier and apparently forgot to reset it. FIXED. LOL so sorry for that!

1 Like