Deep link issues with Reader-augmented text

I don’t know if Hook still works with Reader anymore?
After I clicked “copy selection and link” , the URL shows like this:

>Von dem Quantitativen ist einiges diskret
[Categories Quantity for PDF.pdf](hook://file/68hQvLx0m?p=ZG9uZ2t5L1BERg==&n=Categories%20Quantity%20for%20PDF%2Epdf)

there is no coordinates within the link URL

It works with the Mac App Store version. Do you have a different version?

I installed the MAS version.
Maybe M1 Monterey is the one to blame?

I have tested it on a M1 with Reader 3.0.1 from MAS.

Same: ‎Reader on the Mac App Store app ?

yes , 3.0.1

and I tried again just now ,


There is still no coordinates within the link.

Sorry about that, I read too fast and missed the bit about deep links. Reader is not on our list of apps that support deep linking: Linkable Mac Apps – Hook, see " PDF Readers supporting deep linking (to specific pages)"on that page. So I’m changing this from bug report to feature request.

Not sure if Reader has automation for this. we’ll have a look and check with dev if not. ( Aside: Frode Hegland, the dev, is editor of The Future of Text. I’ve published a couple of chapters in those books. I’ll be attending his regular meeting on Friday morning.)

Sorry about that too. I realized that Reader is a linkable App rather than a ‘deep linkable’ App ,lol

I’ve put this feature request on Frode Hegland Frode’s radar in this morning’s Future of Text meeting. He is very sympathetic to hyperlinking. Next year those meetings will be twice a year. More info to come from Frode about that. We’ll say more about the general concept of hyperlinking on Monday.